Welcome Guest. Please Login or Register  


You are here: Index > Glade Forum > Installation > Topic : Numerical format problem



Threaded Mode | Print  

 Numerical format problem, Numerical format problem (2 Replies, Read 931 times)
dgvic
Group: Member
Post Group: Newbie
Posts: 9
Status:
Hi all,
I have installed glade in linux mint 18 and 17.1, and in both versions I have the same problem. Glade doesn't seem to recognize the '.' as the separator for the decimal part; it recognizes the ',' character.

Since I am in Spain, I am working with the Spanish keyboard layout, but I have setup the OS so that the numerical format recognizes '.' as the decimal separator character. Other applications, such as OpenOffice, work fine and recognize the '.' character.

This is a problem when I load the example.tch file that comes with glade because any of the numerical values inside the file is properly read.

Does anyone has a similar problem? Is this configurable in any way from glade?

Thanks and regards
IP: --   

Numerical format problem
Keith
Group: Moderator
Post Group: Super Member
Posts: 778
Status:
Try setting:

export LC_ALL=C

before running Glade, as a temporary workaround.

For some reason the locale default is not set, which is a bit odd, as I fixed this for a similar problem about a year ago. I can only assume the fix was not properly checked in... I'll try and put this in the 4.5.17 release.
IP: --   

Numerical format problem
dgvic
Group: Member
Post Group: Newbie
Posts: 9
Status:
Hi,
the problem seems to be solved with this workaround.

Thank you!
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is September 25, 2017, 4:11 am.

  Powered By AEF 1.0.9 © 2007-2011 Electron Inc.Queries: 12  |  Page Created In:0.028