Welcome Guest. Please Login or Register  


You are here: Index > Glade Forum > Installation > Topic : Installing Glade on Linux

3


Threaded Mode | Print  

Installing Glade on Linux
Keith
Group: Moderator
Post Group: Super Member
Posts: 776
Status:
Right, this is the plan:

I am going to link the Linux versions to python version 2.6.8. This should get round the _weakref thing as it was not a builtin in that version.

I will have Linux builds available later today. I won't change the version number but will post here when they are ready for download.

- Keith
IP: --   

Installing Glade on Linux
Keith
Group: Moderator
Post Group: Super Member
Posts: 776
Status:
OK all the Linux builds on the web page have been switched to Python 2.6.8. Please re-download them and try them out. Compile date should be today (20th Jan).
IP: --   

Installing Glade on Linux
Ewald
Group: Member
Post Group: Newbie
Posts: 14
Status:
Hello Keith,

Great job! Many thanks.

Glade 4.3.28 in now working under (K)ubuntu 12.04 LTS 64Bit.
See attached screen dump.

Best regards,

Ewald
IP: --   

Installing Glade on Linux
Ewald
Group: Member
Post Group: Newbie
Posts: 14
Status:
Here the screen dump.
IP: --   

Installing Glade on Linux
gsuarez
Group: Member
Post Group: Newbie
Posts: 7
Status:
Hello,

It works on Ubuntu 12.04 64-bit! Thanks.

Rgds,

Georgie
IP: --   

Installing Glade on Linux
Keith
Group: Moderator
Post Group: Super Member
Posts: 776
Status:
One other thing about the Linux installations:

You should set LD_LIBRARY_PATH - so that the $GLADE_HOME/lib directory is found first.

If you don't, you may find that Glade picks up a different version of Qt libs.

In 4.3.37 for example, Glade was switch to Qt 4.8.4 from 4.8.2; it *may* work with the old libs but to be on the safe side check with

Code
ldd glade


which should print a list of tha actual shared libs the application can find.


IP: --   

Installing Glade on Linux
Keith
Group: Moderator
Post Group: Super Member
Posts: 776
Status:
Few points:

Glade built for RHEL4 is no longer actively supported. I have an old build for this that works if you need it; however Qt stopped building on RHEL4 on version 4.8.0 so newer versions of the code cannot run on this old OS.

For RHEL5, same thing has happened with the move to Qt 5.x, as the Qt folks no longer support this OS. I can maintain a branch of the code that will run on Qt 4.8.x for a while but don't want to do this indefinitely.

RHEL6 is stable and supported as it Ubuntu 10.04. Ubuntu 12.04 is now supported and any feedback on problems with this build would be appreciated.
IP: --   

Installing Glade on Linux
Keith
Group: Moderator
Post Group: Super Member
Posts: 776
Status:
I'm interested to know if people are moving to CentOS 7. If you are and would like a specific build for that OS, let me know. CentOS 5 is getting more and more difficult to support, in fact QT 5.x won't compile on it with OpenGL support, so this version is likely to be deprecated soon.
IP: --   

Installing Glade on Linux
Keith
Group: Moderator
Post Group: Super Member
Posts: 776
Status:
One thing about Linux (for those that don't read the README.txt file that comes with the disto):

- Lots of people are using Linux with Mesa OpenGL. Now Mesa is a software emulation of openGL, and its efficiency varies widely, but it's usually pretty bad.

So if you experience slow response, unpredictable effects etc. add to your .bashrc:

export GLADE_USE_OPENGL=no

and this will use Qt's direct rendering capabilities rather than going via OpenGL and an emulator... it will be much faster.

The alternative, if you can, is to have a decent NVidia or similar graphics card (avoid Intel integrated graphics, they have no clue about openGL and their drivers are full of bugs). Install the NVidia driver on your Linux box, and make sure it's being used. This may not work if you are using a VM as usually the VM cannot access the GPU directly. However is you are using VMWare, make sure your're using a recent version (lik v11.x)  and you should get the gallium accelerated drivers.

Note that on Windows and Mac, this should not be a problem as native OpenGL rendering is supported on most modern platforms via a GPU.


Edited by Keith : June 25, 2015, 5:08 pm
IP: --   

Installing Glade on Linux
Keith
Group: Moderator
Post Group: Super Member
Posts: 776
Status:
If you have problems getting Glade to run on Linux, it may be because certain dependencies for the Qt plugins are not being met. For example libfontconfig.

One way of debugging this is to set:

QT_DEBUG_PLUGINS=1

in your shell before launching Glade. It will print out a mass of info on the plugins its trying to load, and any errors found.

btw Glade runs quite well on Windows 10 using a bash shell - the latest win10 version supports Ubuntu 16.04. You need an X server like Xming running on Windows for the graphics to work.
IP: --   

« Previous    Next »

Threaded Mode | Print  

3


Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is July 23, 2017, 2:36 am.

  Powered By AEF 1.0.9 © 2007-2011 Electron Inc.Queries: 12  |  Page Created In:0.023